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Preface 

This guide clearly and concisely sets out the information developers need to know to get started with 
the CASIO Development Media Kit with the integrated Windows® Embedded CE OS development. 
The best methods of connecting to your development system are covered and step by step 
instructions for installing and testing the CASIO Development Kits are included. 
 
The purpose of this guide is to get you to the point where you can start development; you should 
refer to the library manuals for detailed information on the specific APIs. 
 
In this guide, the following name is mentioned by an abbreviation. 
 

Abbreviation Formal name 
WEC7 Microsoft Windows Embedded Compact 7 
WEH6.5 Microsoft Windows Embedded Handheld 6.5 
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1. Product Overview 

1.1 Library Configuration 

This product provides various libraries including those listed in the table. 
 
Table 1.1 

Library Description C++
VB
C# 

System Library Library that is used to control the system. Yes Yes
Laser Scanner Library Library that is used to control the built-in laser scan engine. Yes Yes
Bluetooth Library Library that is used to control the built-in Bluetooth module. Yes Yes
Camera Library Library that is used to control the built-in CAMERA module. Yes Yes
Imager Library Library that is used to control the built-in CMOS Imager. Yes Yes
NFC Library Library that is used to control to communicate with IC card. Yes Yes
NFCMifare Library Library that is used to control to communicate with MIFARE. Yes Yes
NFCFelica Library Library that is used to control to communicate with FeliCa. Yes Yes
NFCHFTag Library Library that is used to control to communicate with ISO15693 

tag. 
Yes Yes

WANGPRS Library Library that is used to control the built-in WANGPRS module. Yes Yes
JPEG Library Library that is used to handle and manipulate JPEG image 

functions. 
Yes - 

FLINK Library Library that is used to control and carry out transmission/reception 
of files between PC and other device. 

Yes Yes

Note: 
The abbreviations used in the table are; 

C++ Visual C++ 
VB Visual Basic .NET 
C# Visual C# .NET 

 
 
Table 1.2 shows each file name of the Dynamic Link Library and Dynamic Link Class Library. 
 
Table 1.2 

Library Dynamic Link Library 
Dynamic Link Library 

(Class Library) 
Common Device Control Library   

System Library SystemLib.dll SystemLibNet.dll 
Laser Scanner Library OBReadLib.dll OBReadLibNet.dll 
Bluetooth Library BluetoothLib.dll BluetoothLibNet.dll 
Camera Library CameraLib.dll CameraLibNet.dll 
Imager Library ImagerLib.dll ImagerLibNet.dll 
NFC Library NFCLib.dll NFCLibNet.dll 
NFCMifare Library NFCMifareLib.dll NFCMifareLibNet.dll 
NFCFelica Library NFCFelicaLib.dll NFCFelicaLibNet.dll 
NFCHFTag Library NFCHFTagLib.dll NFCHFTagLibNet.dll 

 

WANGPRS Library WangprsLib.dll WangprsLibNet.dll 
JPEG Library JpegCe.dll None 
FLINK Library FlinkLib.dll MoFlinkLib.dll 
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1.2 Development Manuals 

This product provides various development reference manuals as described in the table below. 
 
Table 1.3 

Development Manual Description 
Quick Start Guide This reference manual. 
Device Library Base Manual Reference manual that describes the functions list. 
System Library Manual Reference manual that describes individual functions in detail for System 

Library. 
Laser Scanner Library Manual Reference manual that describes individual functions in detail for Laser 

Scanner Library. 
Bluetooth Library Manual Reference manual that describes individual functions in detail for 

Bluetooth Library. 
Camera Library Manual Reference manual that describes individual functions in detail for 

Camera Library. 
Imager Library Manual Reference manual that describes individual functions in detail for Imager 

Library. 
NFC Library Manual Reference manual that describes individual functions in detail for NFC 

Library. 
WANGPRS Library Manual Reference manual that describes individual functions in detail for 

WANGPRS Library. 
JPEG Library Manual Reference manual that describes individual functions in detail for JPEG 

Library. 
FLINK Library Manual Reference manual that describes individual functions in detail for FLINK 

Library. 
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2. Prerequisites 

2.1 Skills Required 

The following skills are required by developers aiming to develop application software. 

 Windows programming 
 A good knowledge of one or more of the following 

- Visual C++ 
- Visual Basic .NET 
- Visual C# .NET 
- Browser based applications (not covered in this guide) 

 
The following skills or experience are also desirable. 

 OS(WEC7, WEH6.5) 
 Windows Mobile Device Center 
 Some networking experience 
 

2.2 System Required 

OS 

 Microsoft Windows 7 Professional 32bit with ServicePack1 
 Microsoft Windows 7 Professional 64bit with ServicePack1 

 

Hardware 

 2.4GHz or higher processor clock speed 
 768MB of RAM or higher 
 1024 x 768 or higher-resolution display 

 
When using Device Emulator for WEC7, below is also required. 

 1024MB of RAM or higher 
 

2.3 Software Required 

The development platform, communication software and SDK provided by Microsoft are required in 
order to develop applications. 
 

Absolutely necessary 

 Microsoft Visual Studio 2008 + Service Pack 1 (not free of charge) 
 Microsoft Windows Mobile Device Center 6.1 

http://www.microsoft.com/downloads/details.aspx?familyid=46F72DF1-E46A-4A5F-A791-09F
07AAA1914&displaylang=en 

 
The following updates are required for Visual Studio 2008 + Service Pack 1 to develop an 
application for WEC7. 
(There is a possibility that following Uniform Resource Locator is changed.) 

 Visual Studio 2008 update for Windows Embedded Compact 7 
http://www.microsoft.com/en-us/download/details.aspx?id=11935 

http://www.microsoft.com/downloads/details.aspx?familyid=46F72DF1-E46A-4A5F-A791-09F07AAA1914&displaylang=en�
http://www.microsoft.com/downloads/details.aspx?familyid=46F72DF1-E46A-4A5F-A791-09F07AAA1914&displaylang=en�
http://www.microsoft.com/en-us/download/details.aspx?id=11935�
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 Windows Embedded Compact 7 ATL Update for Visual Studio 2008 SP1 
http://www.microsoft.com/en-us/download/details.aspx?id=27729 

 
The following SDK is required for Visual Studio 2008 + Service Pack 1 to develop an application 
for WEH6.5. 

 Windows Mobile 6 Professional SDK Refresh 
http://www.microsoft.com/en-us/download/details.aspx?id=6135 

 

Optionally necessary 

When using Device Emulator for WEC7, below is also required. 

 Microsoft Windows Virtual PC  
http://www.microsoft.com/en-us/download/details.aspx?id=3702 

http://www.microsoft.com/en-us/download/details.aspx?id=27729�
http://www.microsoft.com/en-us/download/details.aspx?id=6135�
http://www.microsoft.com/en-US/download/details.aspx?id=3702�
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3. Installing Development Kit for All Models 

3.1 Application Development 

This chapter explains about what you need to set up for the development environment before 
starting your application development. 
 

3.1.1 Application Development for WEC7 

1. Installing Development Platform 
Install Microsoft's development platform which supports Visual Studio 2008. For detail, refer to 
Chapter 2.3 "Software Required". 

 
2. Installing Development Kit to PC 

Install ExportSDK and various libraries. For installation method, refer to Chapter 3.2 "Installing 
Development Kit". 

 
3. Connecting Device to PC (via Windows Mobile Device Center) 

Connect the device to PC via Windows Mobile Device Center. For connection method, refer to 
Chapter 4 "Connecting the Device to PC". 

 
4. Setting up the Development Environment 

Transmit the Casio's libraries to the device. For detail, refer to Chapter 5 "Installing Development 
Kit for Each Model". 

 
5. Installing the Device Emulator 

Install the Device Emulator for WEC7. For installation method, refer to Chapter 6 "Device 
Emulator". If not necessary to install, go to "6. Application Development" below. 

 
6. Application Development 

Now, the application development environment is set up and your development with the 
development platform can be started. After application is developed, transfer it to the Device 
Emulator or an actual terminal of the device via Windows Mobile Device Center for check on the 
operability. For application development method and transferring your application, refer to 
Chapter 7 "Visual Studio". 
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3.1.2 Application Development for WEH6.5 

1. Installing Development Platform 
Install Microsoft's development platform which supports Visual Studio 2008. For detail, refer to 
Chapter 2.3 "Software Required". 
 

2. Installing Development Kit to PC 
Install Microsoft's Windows Mobile 6 Professional SDK Refresh and Casio's Device Library. For 
installation method, refer to Chapter 3.2 "Installing Development Kit". 
 

3. Connecting Device to PC (via Windows Mobile Device Center) 
Connect the device to PC via Windows Mobile Device Center. For connection method, refer to 
Chapter 4 "Connecting the Device to PC". 
 

4. Setting up the Development Environment 
Transmit the Casio's libraries to the device. For detail, refer to Chapter 5 "Installing Development 
Kit for Each Model". 
 

5. Installing the Device Emulator 
Install the Device Emulator for WEH6.5. For installation method, refer to Chapter 6 "Device 
Emulator". If not necessary to install, go to "6. Application Development" below. 
 

6. Application Development 
Now, the application development environment is set up and your development with the 
development platform can be started. After application is developed, transfer it to the Device 
Emulator or an actual terminal of the device via Windows Mobile Device Center for check on the 
operability. For application development method and transferring your application, refer to 
Chapter 7 "Visual Studio". 
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3.2 Installing Development Kit  

Download the Development Kit installation CD image file from the following site and write it to a 
CD-ROM media. 
http://www2.casio.co.jp/system_en/pa/PADealer/  
(The site requires your user name and password. Enter your user name and password as issued by CASIO.) 

 
Notes: 

 You must disable the User Account Control ("UAC") by following the process below before 
installing the Development Kit Files. 

 
  Case of using Windows 7 

- Navigate to Control Panel -> User Accounts -> Change User Account Control 
Settings.  Select Never notify in Choose when to be notified about changed to your 
computer setting. 

 
 
When the Development Kit CD-ROM is inserted in the drive of PC, the following menu screen 
appears automatically. The version number in the menu screen is indicated according to the 
CD-ROM. 

 

Figure 3.1

http://www2.casio.co.jp/system_en/pa/PADealer/�
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3.2.1 Installing ExportSDK 

Please be sure to do the update indicated on Chapter 2.3 "Software Required" before install 
ExportSDK. 
 
Table 3.1 

ExportSDK Device 
CASIO ARMv5 ExportSDK DT-X100 / DT-X200 
CASIO ARMv7 ExportSDK IT-G500 WEC7 Model 

 
In this guide, Installation method of CASIO ARMv5 ExportSDK is explained. 
 
1. Click on Installation List at First Install for All Models. 

 

Figure 3.2 
 
2. Click on CASIO ARMv5 ExportSDK. 

 

Figure 3.3 
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3. Press Next. 

 

Figure 3.4 
 
4. Agree to the software license and press Next. 

 

Figure 3.5 
 
5. Enter the User Name and Organization and press Next. 

 

Figure 3.6 
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6. Select Complete for the Choose Setup Type. 

 

Figure 3.7 
 
7. Change the install destination if necessary and press Next. By default, the software is installed in 

the following locations. 
32bit: C:\Program Files\Windows CE Tools\SDKs\CASIO ARMv5 
64bit: C:\Program Files (x86)\Windows CE Tools\SDKs\CASIO ARMv5 

 

Figure 3.8 
 
8. Press Install. 

 

Figure 3.9 
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9. Press Finish when the install has finished. 

 

Figure 3.10 
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3.2.2 Installing Device Library 

1. Click on Installation List at First Install for All Models. 

 

Figure 3.11 
 
2. Click on CASIO HT Common Development Device Library. 

 

Figure 3.12 
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3. Press Next. 

 

Figure 3.13 
 
4. Agree to the software license and press Next. 

 

Figure 3.14 
 
5. Enter the User Name and Organization and press Next. 

 

Figure 3.15 
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6. Select Complete for the Setup Type. 

 

Figure 3.16 
 
7. Press Install. 

 

Figure 3.17 
 
8. Press Finish when the install has finished. 

 

Figure 3.18 
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3.2.3 Setting the Device Library Path 

Set the device library Path for the ExportSDK. 
The following describes the procedure to set the Path for the CASIO ARMv5 ExportSDK. 
 
1. Navigate to Tools -> Options from the Visual Studio 2008 menu and select VC++ Directory 

under Projects and Solutions. 

 
Figure 3.19 
 
2. Select CASIO ARMv5 (ARMv4I) for the platform and Include files for the project to display 

the directory. (Select Windows Mobile 6 Professional SDK (ARMv4I) / CASIO ARMv5 
(ARMv4I) if you are using the Windows Mobile 6 Professional SDK / CASIO ARMv7 
ExportSDK) 

 
Figure 3.20 
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3. Register the folder installed in Section 3.2.2 "Installing Device Library" as shown in the figure 

below. 
32bit: C:\Program Files\CASIO\MBSYS\INCLUDE 
64bit: C:\Program Files (x86)\CASIO\MBSYS\INCLUDE 

 
Figure 3.21 
 
4. Select Library files for the project to display the directory. 

 
Figure 3.22 
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5. Register the folder installed in Section 3.2.2 "Installing Device Library" as shown in the figure 

below. 
32bit: C:\Program Files\CASIO\MBSYS\LIB\ARMV5 
64bit: C:\Program Files (x86)\CASIO\MBSYS\LIB\ARMV5 
 
Register the following folder if you are using the Windows Mobile 6 Professional SDK. 
32bit: C:\Program Files\CASIO\MBSYS\LIB\ARMV4I 
64bit: C:\Program Files (x86)\CASIO\MBSYS\LIB\ARMV4I 
 
Register the following folder if you are using the CASIO ARMv7 ExportSDK. 
32bit: C:\Program Files\CASIO\MBSYS\LIB\ARMV7 
64bit: C:\Program Files (x86)\CASIO\MBSYS\LIB\ARMV7 

 
Figure 3.23 
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4. Connecting the Device to PC 

4.1 Installing Windows Mobile Device Center 

1. Download the Windows Mobile Device Center Installer to your PC from Microsoft's web site.  
2. Run the installer. 
3. A progress window of installation is displayed. When windows is closed, installation is completed. 
 
The following describes the communication method for connecting device to PC. 
There is 3 kinds of communication method. 
Change the setting according to communication method you will use. 
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4.2 Connection via USB 

To establish connection via USB interface with PC runs in Windows 7, use Windows Mobile Device 
Center ("WMDC"). The device with the factory-setting (default) does not support the WMDC. 
Follow the procedure below to change the setting on the device. 
 
Procedure 
1. Close all applications running on the device. 
2. Start USB Connection. 

In case of WEC7, navigate to Settings -> Control Panel -> USB Connection. 
In case of WEH6.5, navigate to Settings -> System -> USB Connection. 

3. Click Connect Utility tab. 

 
Figure 4.1 

 
4. Choose Windows Mobile Device Center radio button and then click OK button. 

 
Figure 4.2 

 
5. A dialogue asking your final confirmation appears. Click YES button. 

 

Figure 4.3 
 
6. The device starts up again. 
7. Mount the device on the cradle, and then follow a message appeared in the WMDC on the PC. 
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4.3 Connection via WLAN 

To establish communication between the device with the WLAN module integrated and PC via 
WLAN configuration, follow the steps, 1 to 7, below to set up a WLAN configuration on the device. 
After setting up the configuration, be sure to perform a site survey prior to starting communication 
via WLAN. 
 
1. Turn on WLAN power. 

In case of WEC7, navigate to Start -> Settings -> Control Panel -> WLANConfig and then 
check on WLAN Power Enable. 
In case of WEH6.5, navigate to Start -> Settings -> System -> WLAN Power and then 
check on WLAN Power. 

 
Figure 4.4 
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2. Start WLANConfig. 

In case of WEC7, navigate to Start -> Settings -> Control Panel -> WLANConfig and then 
click IP tab. 
In case of WEH6.5, navigate to Start -> Settings -> System -> WLAN Settings and then 
click IP tab. 

 
Figure 4.5 

 
Table 4.1 

Parameter Description 
Enable DHCP or Configure IP Determines "Enable" or "Disable" for DHCP. 
IP Determines IP address. 
MASK Determines subnet mask. 
GateWay Determines default gateway. 
DNS1 Determines primary DNS address. 
DNS2 Determines secondary DNS address. 
WINS1 Determines primary WINS address. 
WINS2 Determines secondary WINS address. 

 
If any of the settings in Figure 4.5 is omitted, the process described in the following table will 
automatically take place in the field. 
 
Table 4.2 

Parameter Nothing is set (DHCP) "Configure IP" is set 
Enable DHCP or 
Configure IP 

"Enable DHCP" is assumed. "Configure IP" is set. 

IP Does not determine IP address. Entered address is set as is. 
MASK Does not determine subnet mask. Entered address is set as is. 
GateWay Does not determine gateway. Entered address is set as is. 
DNS1 Does not determine primary DNS address. Entered address is set as is. 
DNS2 Does not determine secondary DNS address. Entered address is set as is. 
WINS1 Does not determine primary WINS address. Entered address is set as is. 
WINS2 Does not determine secondary WINS 

address. 
Entered address is set as is. 
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3. Click Basic tab. Set up each parameter in the tab by referring to the descriptions for the 

parameters in Table 4.3. 

 
Figure 4.6 

 
Table 4.3 

Parameter Description 
SSID Enter the SSID of the network you want to connect to. 

Disable None. 
WEP Open in Authentication field. 

Security 

WPA PSK in Authentication field (if selected, the Key field must be set also.) 
EAP-PEAP in Authentication field 
EAP-TLS in Authentication field 

Key Enter 26 (maximum) alphanumeric digits (13 hex pairs) in the Key field if 128 bit 
radio button is selected. Or, enter 10 (maximum) alphanumeric digits (5 hex pairs) in 
the Key field if 64 bit radio button is selected. 
 
The field displays the number of characters that have been entered. 
***** in the field implies that the key has been extracted from the ini file. If ***** in 
the field is edited, a new key has been deemed to be set. Or, if it has never been edited, 
the key extracted from the ini file becomes effective as is. 

 
If EAP-PEAP radio button in Authentication field is selected, click the EAP-Properties button 
that appears when selecting the EAP-PEAP radio button to set also the following parameters. 
Table 4.4 

Parameters in 
EAP-Properties screen 

Description Default 

User name Input a user name in alphanumeric (maximum 100 
alphanumeric). 

None 

Password Input a password in alphanumeric (maximum 100 
alphanumeric). 
 
***** in the field implies that the password has been 
extracted from the ini file. If ***** in the field is 
edited, a new password has been deemed to be set. 
Or, if it has never been edited, the password extracted 
from the ini file becomes effective as is. 

None 

Domain Input a domain in alphanumeric (maximum 100 
alphanumeric). 

None 

Validate server 
certificate 

 Set up the requisition for server certificate. 
With check mark   : certificate is required. 
Without check mark: certificate is not required. 

Certificate is not necessary
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If EAP-TLS radio button in Authentication field is selected, click the EAP-Properties button that 
appears when selecting the EAP-TLS radio button to set the following settings. 
 
Table 4.5 

Parameters in 
EAP-Properties screen 

Description Default 

User name Input a user name in alphanumeric (maximum 100 
alphanumeric). 

None 

Certificate Select a client certificate installed already (maximum 
100 alphanumeric). 
 
Search button in the field will display a list of 
installed client certificates. Select one by highlighting 
it. 

None 

Domain Input in alphanumeric (maximum 100 alphanumeric) None 
Validate server 
certificate 

Set up the requisition for server certificate. 
With check mark   : certificate is required. 
Without check mark : certificate is not required. 

Certificate is required. 

 
4. Click WLAN tab. 

 
Figure 4.7 

 
Table 4.6 

Field / Radio 
Buttons 

Description Default

On Enable power to the integrated WLAN module. Yes Power 
Off Disable power to the integrated WLAN module.  
Enable Enable power save mode for the WLAN module. Yes Save 
Disable Disable power save mode for the WLAN module.  

Standard  Set up IEEE802.11 standard effect. Abgn 
No roaming Set up "-100 dBm" for roaming starting threshold level, a 

level where communication via WLAN is practically 
impossible, so that roaming should not be carried out.   

 

Default Set up "-78 dBm" for the roaming starting threshold level. Yes 
High Set up "-72 dBm" for roaming starting threshold level, for 

faster (more frequent) roaming 
 

RSSI Level for 
initiating roaming 

Value Set up roaming starting threshold level manually.  
None Automatic switching to the highest strength network in 

2.4GHz or 5GHz. 
Yes 

2.4GHz Automatic switching to 2.4GHz if a network that is 
stronger than Range value is found.  

 

Band priority 

5GHz Automatic switching to 5GHz if a network that is stronger 
than Range value is found. 
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5. Click Detail tab. 

  
Figure 4.8 

 
Table 4.7 

Field / Radio Buttons Description Default 
WLANConfig, 
NetSearch 

- Use only CASIO provided WLAN tool. 
- Configure WLAN setting with settings 

extracted from the ini file. 
- Initiate NetSearch when tapping the icon in 

the task tray. 

Yes 
 

WLANConfig,  
NetUI 

- Use both CASIO provided WLAN tool and 
MS tool. 

- Configure WLAN setting with settings 
extracted from the ini file. 

- Initiate NetUI (MS tool) when tapping the 
icon in the task tray.  

 

WLAN configure,  
Status display tool 

NetUI/NetUI - Use only the MS tool. 
- Configure WLAN setting, not with settings 

extracted from the ini file. 
- Initiate NetUI when tapping the icon in the 

task tray. 
 
If this radio button is selected and the OK button 
that appears in the subsequent popup warning 
message is clicked, other settings in the ini file 
will be deleted. Only the WLAN configuration 
set with NetUI is saved.  

 

With check mark : enable the setting.  Enable adhoc network setting 
Without check mark : disable the setting. Yes 
With check mark : enable the setting.  Enable all authentication settings 
Without check mark : disable the setting.  Yes 

Inifile comment Enter a comment of up to 100 characters to be 
written in the ini file. 

None 
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6. If OK button in the popup warning message (see Table 4.7 for description of NetUI/NetUI radio 

button) is clicked, the screen in Figure 4.9 appears. Click OK button to perform a reset on the 
terminal so that the setting takes effect. 

 
Figure 4.9 

 
7. Check to make sure that the connection has been established using the NetSearch utility, and 

then navigating to the Ping function in there. Enter HostName first and then click Ping to check 
that you are connected to the network correctly. 
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4.4 Connection via Ethernet Cradle 

This chapter describes how to establish a high speed LAN connection. 
 
1. Connect the dedicated AC adapter to the Ethernet cradle. 
2. Connect one end of the network cable to the Ethernet cradle and the other end to the network hub. 
3. Make sure the selector switch on the back of the Ethernet cradle is set to the position LAN. 

 
Figure 4.10 
 
4. Place the device in the cradle. 
5. Navigate to Settings -> Control Panel -> Network and Dial-up Connections on the 

device. 
6. The following screen appears. Double click the AX887721 icon. The icon will not appear unless 

the terminal is placed in the cradle. 

 
Figure 4.11 
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4.5 Accessing Shared Network Drive on Your LAN 

Assuming you have a valid network connection established, you can access shared drives on your 
PC from the File Explorer on the device. The following shows the steps to initiate this.  
 

Procedure in WEC7 

1. Configure a network connection on the device. 
2. Double click My Device. 
3. Navigate to View -> Address Bar. 
4. Type \\xxxx\ where xxxx is the network name of the PC. 
5. A network logon dialog box will appear. Enter a valid User ID, Password and Network Domain. 
6. Any shared network drives on the target PC will be displayed and you will be able to copy files 

freely between them and the device. 
 

3.  4.  

  
  
5.   
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Procedure in WEH6.5 

1. Configure a network connection on the device. 
2. Double tap My Device. 
3. Type \\xxxx\ where xxxx is the network name of the PC. 
4. A network logon dialog box will appear. Enter a valid User ID, Password and Network Domain. 
5. Any shared network drives on the target PC will be displayed and you will be able to copy files 

freely between them and the device. 
6. Any shared network drives on the target PC will be displayed and you will be able to copy files 

freely between them and the device. 
 

3.  4.  

  
  
5.   
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4.6 Capturing Screenshot 

If you connect the device to PC, you can capture a screenshot. The following shows the steps to 
initiate this. 
 
1. Launch Start Menu > Microsoft Visual Studio 2008 > Visual Studio Remote Tools > Remote 

Zoom In. 

 
 

2. Select the device connecting to PC and push OK button. 
 

SDK Device 
CASIO ARMv5 Device DT-X100 / DT-X200 
CASIO ARMv7 Device IT-G500 WEC7 Model 
CASIO x86 Device Device Emulator for WEC7 
Windows Mobile 6 Professional Device IT-G500 WEH6.5 Model / Device Emulator for 

WEH6.5 
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4.7 Direct TCP/IP Connection from Visual Studio 

If you have a network connection to the device (for example, via WLAN or the Ethernet cradle) then 
you can establish a direct link to the development PC without using Windows Mobile Device 
Center. 
 
For Visual Studio 2008 
1. Download the files listed below to the device. 

- Clientshutdown.exe 
- ConmanClient2.exe 
- CMAccept.exe 
- DeviceDMA.dll 
- eDbgTL.dll 
- TcpConnectionA.dll 

 
The source folder in the PC: 

C:\Program Files\Common Files\Microsoft Shared\CoreCon\1.0\Target\wce400\armv4i 
The destination folder in the device: 

\Windows 
 
2. Run ConmanClient2.exe on the device. 
3. Set the device IP address in Visual Studio 2008.  
4. Navigate to Tools in the main menu of Visual Studio 2008 -> Options… -> Device Tools -> 

Devices.  
5. Choose Device in the pull-down menu of Devices: and click Properties…. 
6. Click Transport: to access Configure… and set up Device IP address as shown in Figure 

4.12. 

 

Figure 4.12 
 

7. Run CMAccept.exe on the device. 
8. Navigate to Tools in the main menu of Visual Studio 2008 -> Connect to Device…. 
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9. Choose Device in the list of Devices: and click Connect button. The screen in Figure 4.13 if 

appear indicates the success of connection establishment. 
 

 

Figure 4.13 
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5. Installing Development Kit for Each Model 

5.1 Installing Device Library for Each Model 

After installing Device Library for Each Model, the CAB files in Table 5.1 will be installed in the 
folder below. 
 

The contents of CAB files 

CAB files are installed in the following folder by default. Following AAA is model name. 
32bit: C:\Program Files\CASIO\MBSYS\CAB\AAA 
64bit: C:\Program Files (x86)\CASIO\MBSYS\CAB\AAA 
 
The run-time library described on the following table is stocked in CAB files. Following AAA is 
model name, BBB is OS name, and CCC is version information. The name of cab file which install 
System Library Version 3.01 to IT-G500 is SystemLibITG500WEHE.301.CAB. 
 
Table 5.1 

Library CAB file 
System Library SystemLib[AAABBB]E.[CCC].CAB 
Laser Scanner Library OBReadLib[AAABBB]E.[CCC].CAB 
Bluetooth Library BluetoothLib[AAABBB]E.[CCC].CAB 
Camera Library CameraLib[AAABBB]E.[ CCC].CAB 
Imager Library ImagerLib[AAABBB]E.[ CCC].CAB 
JPEG library JpegCe[AAABBB]E.[ CCC].CAB 
FLINK library Flink[AAABBB]E.[ CCC].CAB 
NFC Library NFCLib[AAABBB]E.[ CCC].CAB 
WANGPRS Library WANGPRSLib[AAABBB]E.[CCC].CAB 

Notes: 
1. When using Device Emulator, these CAB files are already installed. So it is not necessary 

to install these files. 
2. The name of CAB file and the kind depend on the model. 
3. About the library available on each model, refer to Device Library Base Manual. 
4. The latest library is enclosed in ServicePack for each model. Refer to CASIO support page 

for the latest ServicePack. 
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Installation procedure 

In this guide, the following describes the procedure to install Device Library for DT-X200 to 
device. 
 

(1) Installing to PC 

Click on Installation List at Second Install for Each Model. 

 

Figure 5.1 
 
Click on CASIO HT Development Media Kit Device Library for DT-X200. 

 

Figure 5.2 
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Press Next. 

 

Figure 5.3 
 
Agree to the software license and press Next. 

 

Figure 5.4 
 
Enter the User Name and Organization and press Next. 

 

Figure 5.5 
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Select Complete for the Setup Type, press Next. 

 

Figure 5.6 
 
Press Install. 

 

Figure 5.7 
 
Press Finish when the install has finished. 

 

Figure 5.8 
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(2) Transmission of a CAB file 

Transfer each CAB file to any folder on DT-X200 by Windows Mobile Device Center. 

 

Figure 5.9 
 
Notes: 

 In this guide, CAB file is placed on root folder of DT-X200. 
 For use method of Windows Mobile Device Center, refer to Chapter 4 "Connecting the Device 

to PC". 
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(3) Installation of a CAB file 

Execute transmitted CAB file. 

 

Figure 5.10 
 
Press Enter Key on hardware or software keyboard. 
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(4) Installation completion 

 
Figure 5.11 
 

 In this guide, Installation of System Library is described for example. Also install other libraries 
by the same procedure. 

 If you execute Full Reset on device, install again. 
 

System Library becomes available by the above mentioned procedure. 
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6. Device Emulator 

Device Emulator provides to application developers as "an environment which enables the 
confirmation of basic application behavior and source-level debugging without the actual device". 
 

Figure 6.1  Device Emulator Figure 6.2  I/O Simulator 
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6.1 Device Emulator for WEC7 

6.1.1 Installing ExportSDK 

1. Click on Installation List at First Install for All Models. 

 

Figure 6.3 
 
2. Click on CASIO x86 ExportSDK.  

 

Figure 6.4 
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3. Press Next. 

 

Figure 6.5 
 
4. Agree to the software license and press Next. 

 

Figure 6.6 
 
5. Enter the User Name and Organization and press Next. 

 

Figure 6.7 
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6. Select Complete for the Choose Setup Type. 

 

Figure 6.8 
 
7. Change the install destination if necessary and press Next. By default, the software is installed in 

the following locations. 
32bit： C:\Program Files\Windows CE Tools\SDKs\CASIO x86 
64bit： C:\Program Files (x86)\Windows CE Tools\SDKs\CASIO x86 

 

Figure 6.9 
 
8. Press Install. 

 

Figure 6.10 
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9. Press Finish when the install has finished. 

 

Figure 6.11 
 

6.1.2 Installing Device Library 

Installing the development kit device library also installs the VirtualPC device library. Refer to 
Section 3.2.2 "Installing Device Library" for details about the installation method. 
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6.1.3 Installing Device Emulator 

Install the Windows Embedded Compact 7 Emulator Image for CASIO. 
VirtualPC is located in the following directory in CD-ROM.  
   SETUP\COMMON\DEVICEEMULATOR\VIRTUALPC 
 
1. Copy the VirtualPC folder above to an arbitrary directory on your PC. 

This guide uses the example of copying the folder to C:\DT-X200\.  
 
2. Navigate to Windows Virtual PC from the Start menu and select Create virtual machine. 

 
Figure 6.12 
 
3. Enter the Name and Location and press Next. 

The name in this example is CASIO_vCEPC. 

 

Figure 6.13 
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4. Enter a value of 256 MB or greater for the RAM, check the Use computer network 

connection option and press Next. By changing this value, Storage memory and Program 
memory are changed in Device Emulator. 

 

Figure 6.14 
 
5. Select the CASIO_vCEPC_E.vhd created in step 1 as the Location for Use an existing 

virtual hard disk and press Create. 
WQVGA  : CASIO_vCEPC_WQVGA_E.vhd 
Other resolutions : CASIO_vCEPC_E.vhd 

 

Figure 6.15 
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6. Select the CASIO_vCEPC.vmcx created in step 5 and press Settings.  

 
Figure 6.16 
 
7. Select the CASIO_FLASHDISK_E.vhd item installed in step 1 for Hard Disk 2 and press 

OK. 

 

Figure 6.17 
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6.1.4 Starting Up Device Emulator 

Start up the CASIO VirtualPC. 
 
1. Double click the CASIO_vCEPC.vmcx created in Section 6.1.3 "Installing Device Emulator" 

to display the screen below. 

 

Figure 6.18 
 
2. Device Emulator will launch after a brief wait. (The software may take several minutes to start up 

depending on the environment.) 

 
Figure 6.19 



 

 53

 

6.1.5 Relating ExportSDK to Device Emulator 

Relate CASIO x86 SDK installed in Section 6.1.1 "Installing ExportSDK" to Device Emulator. 
 
1. While referring to section 6.1.4 "Starting Up Device Emulator", start Device Emulator, 

double-click the   icon on the taskbar and skip the IP address. 

 
Figure 6.20 
 
2. Navigate to Tools -> Options from the Visual Studio 2008 menu and select Devices from the 

Device Tools. 

 
Figure 6.21 
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3. Select CASIO x86 Device from the device list and press Properties. 

 
Figure 6.22 
 
4. Press Configure under Transport. 

 

Figure 6.23 
 
5. Enter the IP address that was skipped in step 1 for the Use specific IP address and press OK. 

 
Figure 6.24 
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6. Navigate Tools -> Connect to Device from the Visual Studio 2008 menu, select CASIO x86 

for the platform and press Connect. 

 
Figure 6.25 
 
7. Device Emulator setting has succeeded if Connection succeded is displayed as in the figure 

below. If a message other than the one shown below is displayed, please check that the IP address 
entered matches the Device Emulator IP address. 

 

Figure 6.26 
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6.1.6 Setting the Device Emulator Screen Resolution 

Set the screen resolution of Device Emulator. 
The default starts up with a resolution of 480x800. 
The following example describes the procedure to start up with a screen resolution of 480x640. 
 
1. Start Device Emulator and press the space key while the screen below is displayed. 

 

Figure 6.27 
 
2. Press 5 on the keyboard when the Main Menu of the Device Emulator Bootloader starts. 

 

Figure 6.28 
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3. Press 3 on the keyboard when the Display Settings starts. 

 

Figure 6.29 
 
4. Press the h key on the keyboard when the Select Display Mode starts. 

 

Figure 6.30 
 
5. Press the 0 key to return to the Display Settings. 

 

Figure 6.31 
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6. If you will start Device Emulator at a resolution of 480x640 from now on, then press the 7 key to 

save the settings and then the 0 key to start Device Emulator. 
 
If you will start Device Emulator at a resolution of 480x640 just one time, then press the 0 key to 
start Device Emulator. 

 

Figure 6.32 
 
7. Device Emulator will start up at a resolution of 480x640. (The software may take several minutes 

to start up depending on the environment.) 

 
Figure 6.33 
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6.1.7 Setting the Device Emulator Disk Size 

The default size of FlashDisk is 512MB in Device Emulator. Follow the procesure below to increase 
the size of FlashDisk in Device Emulator. These screens are different depending on the 
environment. 
 
1. Start Run, enter diskmgmt.msc and click OK. 

 

Figure 6.34 
 
2. Disk Management will start. Navigate to Action -> Create VHD. 

 
Figure 6.35 
 
3. Enter the location and name of FlashDisk that is newly created to Location. And enter the size 

of FlashDisk to Virtual hard disk size. Select Dynamically expanding at Virtual hard 
disk format and click OK. 
In this guide, FlashDisk having a size of 4GB is created to 
C:\DT-X200\CASIO_FLASHDISK_E_4G.vhd. 

 
Figure 6.36 
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4. Right-click on the disk created in Step 3. Select Initialize Disk. Disk number is different 

depending on the environment. 

 
Figure 6.37 
 
5. Select only the disk created in Step 3 at Select disks. And select MBR at Use the following 

partition style for the selected disks. Click OK. 

 

Figure 6.38 
 
6. Make sure that the following red frame in is Online. If Not Initialized is shown, start again 

from Step 4. Right-click on the place where Unallocated is being displayed, please select the 
New Simple Volume. 

 
Figure 6.39
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7. New Simple Volume Wizard will start. Click Next. 

 
Figure 6.40 
 
8. Enter the same value as Maximum disk space in MB to Simple volume size in MB. Click 

Next. 

 
Figure 6.41 
 
9. Select the drive letter not in use at Assign the following drive letter. Click Next. 

 

Figure 6.42 



 

 62

 
10. Select FAT32 at File system and empty the field of Volume label. Click Next. 

 
Figure 6.43 
 

11. Make sure that the settings are correct. Click Finish. 

 

Figure 6.44 
 

12. Return to Disk Management. Navigate to Action -> Attach VHD. 

 
Figure 6.45 
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13. Select existing FlashDisk at Location. Click OK. 

In this guide, C:\DT-X200\CASIO_FLASHDISK_E.vhd is selected. 

 

Figure 6.46 
 

14. Copy all folders and all files in the disk attached in Step 13 by explorer. And paste the folders and 
the files to the disk created in Step 3. 

 
15. Return to Disk Management. Right-click on the disk created in Step 3. Select Detach VHD. 

 
Figure 6.47 
 

16. Make sure that the disk created in Step 3 is displayed at Virtual hard disk file location. Click 
OK. 

 
Figure 6.48 
 

17. By the same procedure, detach the disk that is attached in Step 13. 
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18. Select the file for Device Emulator named CASIO_vCEPC.vmcx. And click Settings. 

 
Figure 6.49 
 

19. Select the disk created in Step 3 for Hard Disk 2. Click OK. 

 

Figure 6.50 
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6.2 Device Emulator for WEH6.5 

6.2.1 Installing Device Emulator 

1. Click on Installation List at First Install for All Models. 

 

Figure 6.51 
 
2. Click on CASIO Device Emulator WVGA for Windows Embedded Handheld 6.5. 

(Select CASIO Device Emulator VGA for Windows Embedded Handheld 6.5 if you are 
using the VGA Emulator.) 

 

Figure 6.52 
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3. Press Next. 

 

Figure 6.53 
 
4. Agree to the software license and press Next. 

 

Figure 6.54 
 
5. Enter the User Name and Organization and press Next. 

 

Figure 6.55 
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6. Change the install destination if necessary and press Next. By default, the software is installed in 

the following locations. 
32bit: C:\Program Files\Windows Mobile 6 SDK  
64bit: C:\Program Files (x86)\Windows Mobile 6 SDK 

 

Figure 6.56 
 
7. Press Install. 

 

Figure 6.57 
 
8. Press Finish when the install has finished. 

 

Figure 6.58 
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6.2.2 Starting Up Device Emulator 

It requires installation of I/O Simulator to start up Device Emulator. For installation method, refer to 
Chapter 6.3.1 "Installing I/O Simulator". There are WVGA Device Emulator and VGA Device 
Emulator. In this guide, starting up method of WVGA Device Emulator is explained. 
 
1. Navigate to Start -> CASIO Device Emulator -> WEH6.5 WVGA. When using VGA Device 

Emulator, navigate to Start -> CASIO Device Emulator -> WEH6.5 VGA. 
2. Device Emulator will launch. 

 

Figure 6.59 
 

6.2.3 Connecting to Device Emulator 

Setting Windows Mobile Device Center 

1. Start up Windows Mobile Device Center and then navigate to Mobile Device Settings -> 
Connection Settings. 

2. In Connection Settings screen, check in the Allow connections to one of the following 
box and choose DMA in the pull-down menu. 

 
Figure 6.60 



 

 69

 

Connection via Windows Mobile Device Center 

1. Navigate to Tools -> Device Emulator Manager… from the Visual Studio 2008 menu. 
2. Right click on CASIO WEH6.5 WVGA Emulator and select Cradle. 

 
Figure 6.61 
 

3. Windows Mobile Device Center launches and the  icon appears on status bar in Device 
Emulator. 
 

6.3 I/O Simulator 

The next section continues by explaining how to install the software needed to use the I/O simulator. 
 

6.3.1 Installing I/O Simulator 

If the old version of CASIO IO Simulator is already installed, uninstall it. And if there is CASIO 
Device Emulator in list of Uninstall a program of Control Panel, also uninstall it. After the 
uninstallation has been completed, follow the procedure below to install CASIO IO Simulator. 
 
1. Install the CASIO IO Simulator in the Installation List at First Install for All Models on the 

product CD-ROM. 

 

Figure 6.62 
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2. Enable sharing for the following folder, if you will use Device Emulator for WEC7. Enable read 
and write access permissions. 
C:\ProgramData\CASIO 

 

6.3.2 Starting Up I/O Simulator 

1. Navigate to CASIO Device IO Simulator on start menu. 
2. Following message is displayed. If you will use Device Emulator for WEC7, press Yes. 

 

Figure 6.63 
 
3. IO Simulator and Key Simulator start. 

    

Figure 6.64 
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6.3.3 Operating I/O Simulator 

The I/O Simulator simulates registration of bar codes, generation of low battery warning, detection 
of terminal being mounted on the cradle.  

 
Registration of bar code symbologies 
1. Registration 

Click ADD1D or ADD2D button (circled in red in Figure 6.65) to go into the bar code 
registration mode. 

 
Figure 6.65 

 
2. Bar code registration 

Choose a bar code symbology in the Code Type pull-down menu that you wish to register in 
the I/O Simulator. 

 
Figure 6.66 
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3. Registration of bar code and note 

Enter bar code data in the Code field (see Figure 6.67) and a note about the bar code in the 
Note field if necessary. Click OK button to complete the bar code registration. 

 

Figure 6.67 
 

4. Completion of registration 
After completion of the bar codes registration, the screen in Figure 6.68 shows a list of bar 
codes that have been registered in the I/O Simulator. Prior to debugging with the Device 
Emulator, make sure that you register all bar codes you wish to use in debugging. 

 

Figure 6.68 
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5. Editing registered bar code content 

Highlight a bar code in the list of registered bar codes (see Figure 6.68) and click Edit button. 
Figure 6.69 appears for editing the bar code and its information.  

 

Figure 6.69 
 

6. Deleting registered bar code content 
Highlight a bar code in the list of registered bar codes (see Figure 6.68) and click the Del 
button. Dialogue screen in Figure 6.70 appears for you to confirm the deletion. If it is okay to 
delete, click Yes button, otherwise click No button. 

 
Figure 6.70 
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Detection of Terminal in Cradle and Low Battery Warning 
If you check the I/O Box and Low Battery boxes in STATE SETTING field (see Figure 6.71), the 
simulator simulates the respective events in the emulator.  

 
Figure 6.71 

 

I/O Box 
If this box is checked, a notification is issued that the connection between the Device Emulator 
and cradle has been established. This notification can be utilized by the application.   
 

Low Battery 
If this box is checked, a notification that a low battery state has occurred is raised. The icon in the 
Toolbar in the emulated screen appears too. The notification can be utilized by the application to 
recognize the low battery state in the hardware. 
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Indications 

The I/O Simulator expresses a change of state that occurred in the Device Emulator. 
 

 LED 
When the Device Emulator turns on the LED, the LED icon (LED2) in the I/O Simulator also turns on. See 
Figure 6.72. 

 Vibration 
When the Device Emulator vibrates, the vibration icon in the I/O Simulator also turns on. See Figure 6.72. 
 

 

Figure 6.72 
 

Keys 

A key event is notified to Device Emulator by input on the Key Simulator. 
If you use key which doesn't exist in Key Simulator, input by keyboard of PC. 

 

Figure 6.73
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7. Visual Studio 

This chapter describes application development steps in Visual Studio 2008 to create an example 
program. 
 
The example program referred to in this chapter is an application program developed in three 
development environments - C++, Visual Basic and C# - using the CASIO Common Device Control 
Library or Common Device Control Class Library. The example program for all three environments 
repeats turning on and off the LED to brink for a period of 5 seconds. 
 
The example program in this chapter runs also in the Device Emulator. 
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7.1 Developing in VB 

This chapter describes necessary steps to develop the example application program in VB 
environment using the Common Device Control Class Library. 
 

Application Development Procedure 

Subsequent steps show how to create and start up a simple program using one of the system 
functions. When running the program, the LED will blink in red for 5 seconds. 
 
1. Create a new VB Smart Device Application in Visual Studio. 

 

Figure 7.1 
 
2. Select WindowsCE for Target platform and select Device Application from Templates. 

 
Figure 7.2 
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3. Navigate to Project -> Add Reference from the Visual Studio 2008 menu. 

 

Figure 7.3 
 
4. Click Browse tab. 

 
Figure 7.4 
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5. Reference folder which Class Library is installed, and select SystemLibNet.dll. 

32bit: C:\Program Files\CASIO\MBSYS\WindowsCE 
64bit: C:\Program Files (x86)\CASIO\MBSYS\WindowsCE 

 
Figure 7.5 
 
6. Click OK to close the dialog. 
 
 
7. Change form size to 240,320 by form property. 
8. Add a button to the form, rename it SetLED. 

 
Figure 7.6 
 
9. Double click the button. named SetLED to display code of the form. 
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10. In the event function for the button to click, add the following code. 

Dim result As Int32 

Dim msg As String 

 

result = Calib.SystemLibNet.Api.SysSetLED( _ 

            Calib.SystemLibNet.Def.LED_RED, 5, 8, 8) 

 

'.NET vales of "true" and "false" are "-1" and "0" respectively. 

If result = -1 Then 

    result = Calib.SystemLibNet.Api.SysGetLED() 

    Select Case (result And &HF) 

        Case Calib.SystemLibNet.Def.LED_OFF 

            msg = "LED_OFF" 

        Case Calib.SystemLibNet.Def.LED_RED 

            msg = "LED_RED" 

        Case Calib.SystemLibNet.Def.LED_GREEN 

            msg = "LED_GREEN" 

        Case Calib.SystemLibNet.Def.LED_ORANGE 

            msg = "LED_ORANGE" 

        Case Calib.SystemLibNet.Def.LED_BLUE 

            msg = "LED_BLUE" 

        Case Calib.SystemLibNet.Def.LED_CYAN 

            msg = "LED_CYAN" 

        Case Calib.SystemLibNet.Def.LED_MAGENTA 

            msg = "LED_MAGENTA" 

        Case Else 

            msg = "LED_UNKNOWN" 

    End Select 

    MessageBox.Show(msg, "LED") 

End If 

 
Note:  
If you type this code manually you should see the IntelliSense offer you suitable options as 
appropriate. If you do not, make sure you review steps 1 to 5 to make sure you have added the 
reference correctly. 
 

11. Navigate to Build -> Build Solution from the Visual Studio 2008 menu to build application. 
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12. Initiate Windows Mobile Device Center to establish connection between the device and PC. 

 
13. Choose Deploy <name of project> on Build menu. 

 
Figure 7.7 
 
Table 7.1 

Build menu Device 
CASIO ARMv5 Device DT-X100 / DT-X200 
CASIO ARMv7 Device IT-G500 WEC7 Model 
CASIO x86 Device Device Emulator for WEC7 
Windows Mobile 6 Professional Device IT-G500 WEH6.5 Model 
CASIO WEH6.5 WVGA Emulator WVGA Device Emulator for WEH6.5 
CASIO WEH6.5 VGA Emulator VGA Device Emulator for WEH6.5 

 
14. Navigate to Debug -> Start Debugging or Start Without Debugging from the Visual 

Studio 2008 menu. 
 
The project will be built and copied to the device. By default, it will be copied to \Program 
Files\<name of project> folder. SystemLibNet.dll will be deployed to the same folder. 
 
Check that the program works correctly on the device. 
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7.2 Developing in C# 

This chapter describes necessary steps to develop the example application program (see Chapter 8) 
in C# environment using the Common Device Control Class Library. 
 

Application Development Procedure 

Subsequent steps show how to create and start up a simple program using one of the system 
functions. When running the program, the LED will blink in red for 5 seconds. 
 
1. Create a new C# Smart Device Application in Visual Studio .NET. 

 

Figure 7.8 
 
2. Select WindowsCE for Target platform and select Device Application from Templates. 

 
Figure 7.9 
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3. Navigate to Project -> Add Reference from the Visual Studio 2008 menu. 

 

Figure 7.10 
 
4. Click Browse tab. 

 
Figure 7.11 



 

 84

5. Reference folder which Class Library is installed, and select SystemLibNet.dll. 
32bit: C:\Program Files\CASIO\MBSYS\WindowsCE 
64bit: C:\Program Files (x86)\CASIO\MBSYS\WindowsCE 

 
Figure 7.12 
 
6. Click OK to close the dialog. 
 
 
7. Change form size to 240,320 by form property. 
8. Add a button to the form, rename it SetLED. 

 
Figure 7.13 
 
9. Double click the button. named SetLED to display code of the form. 
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10. At the top of your source file add the following code.  

using Calib; 

 
11. Add a button to your form, rename it LED and double click it and then add the following code: 

Int32 result = new Int32(); 

string msg; 

 

result = SystemLibNet.Api.SysSetLED(SystemLibNet.Def.LED_RED, 5, 

8, 8); 

 

// .Net values "true" and "false" are "-1" and "0" respectively. 

if(result == -1) 

{ 

    result = SystemLibNet.Api.SysGetLED(); 

    switch(result & 0x0000000F)  

    { 

        case SystemLibNet.Def.LED_OFF: 

            msg = "LED_OFF"; 

            break; 

        case SystemLibNet.Def.LED_RED: 

            msg = "LED_RED"; 

            break; 

        case SystemLibNet.Def.LED_GREEN: 

            msg = "LED_GREEN"; 

            break; 

        case SystemLibNet.Def.LED_ORANGE: 

            msg = "LED_ORANGE"; 

            break; 

        case SystemLibNet.Def.LED_BLUE: 

            msg = "LED_BLUE"; 

            break; 

        case SystemLibNet.Def.LED_CYAN: 

            msg = "LED_CYAN"; 

            break; 

        case SystemLibNet.Def.LED_MAGENTA: 

            msg = "LED_MAGENTA"; 

            break; 

        default: 

            msg = "LED_UNKNOWN"; 

            break; 

    } 

    MessageBox.Show( msg, "LED"); 

} 

 

Note: 
If you add this code manually you should see the IntelliSense offer you suitable options as 
appropriate. If you do not see this, then review steps 2 to 4 in the previous page to make sure you 
have not made a mistake. 
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12. Navigate to Build -> Build Solution from the Visual Studio 2008 menu to build application,. 

 
13. Initiate Windows Mobile Device Center to establish connection between the device and PC. 

 
14. Select Deploy <name of project> on Build menu. 

 
Figure 7.14 
 
Table 7.2 

Build menu Device 
CASIO ARMv5 Device DT-X100 / DT-X200 
CASIO ARMv7 Device IT-G500 WEC7 Model 
CASIO x86 Device Device Emulator for WEC7 
Windows Mobile 6 Professional Device IT-G500 WEH6.5 Model 
CASIO WEH6.5 WVGA Emulator WVGA Device Emulator for WEH6.5 
CASIO WEH6.5 VGA Emulator VGA Device Emulator for WEH6.5 

 
15. Navigate to Debug -> Start Debugging or Start Without Debugging from the Visual 

Studio 2008 menu. 
 
The project will be built and copied to the device. By default, it will be copied to \Program 
Files\<name of project> folder. SystemLibNet.dll will be deployed to the same folder. 
 
Check that the program works correctly on the device. 
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7.3 Developing in C++ 

This chapter describes necessary steps to develop the example application program in C++ 
environment using the Common Device Control Library. 
 
1. Create a new C++ Win32 Smart Device Project in Visual Studio 2008. 

 

Figure 7.15 
 
2. Press Next. 

 
Figure 7.16 
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3. Choose Windows Mobile 5.0 Pocket PC SDK in the Selected SDKs field in the Platforms of 

Win32 Smart Device Project Wizard and click < button. 

 
Figure 7.17 
 
4. Choose SDK for device which you will use in the Installed SDKs field and click > button. 

In this guide, 2 of all SDK is chosen. 

 
Figure 7.18 
  
Table 7.3 

SDK Device 
CASIO ARMv5 DT-X100 / DT-X200 
CASIO ARMv7 IT-G500 WEC7 Model 
CASIO x86 Device Emulator for WEC7 
Windows Mobile 6 Professional SDK IT-G500 WEH6.5 Model / Device Emulator for 

WEH6.5 
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5. Confirm that there are CASIO ARMv5, CASIO ARMv7, CASIO x86 and Windows Mobile 

6 Professional SDK in the Selected SDKs field, and press Next. 

 
Figure 7.19 
 
6. Choose Console application for the Application type in the Application Settings menu, and 

press Finish. 

 
Figure 7.20 
 
7. In Solution Explorer, click DeviceApp.cpp and then append the source code below subsequent 

to "#include <commctrl.h>". 
 

#include <SystemLib.h> 

#if !defined(_countof) 

#define _countof(_Array) (sizeof(_Array) / sizeof(_Array[0])) 

#endif 
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8. Append the source code below in the main function of DeviceApp.cpp. 

    DWORD result; 

    TCHAR msg[16]; 

 

    result = SysSetLED(LED_RED, 5, 8, 8); 

 

    if(result == TRUE) 

    { 

        result = SysGetLED(); 

        switch(result & 0x0000000F) { 

        case LED_OFF: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_OFF") ); 

            break; 

        case LED_RED: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_RED") ); 

            break; 

        case LED_GREEN: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_GREEN") ); 

            break; 

        case LED_ORANGE: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_ORANGE") ); 

            break; 

        case LED_BLUE: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_BLUE") ); 

            break; 

        case LED_CYAN: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_CYAN") ); 

            break; 

        case LED_MAGENTA: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_MAGENTA") ); 

            break; 

        default: 

            wcscpy_s( msg, _countof(msg), TEXT("LED_UNKNOWN") ); 

            break; 

        } 

        MessageBox(NULL, msg, TEXT("LED"), MB_OK); 

    } 

 
9. Navigate to Build -> Compile from the Visual Studio 2008 menu to build application. 

 
10. Navigate to Project -> DeviceApplication1 Properties from the Visual Studio 2008 menu.
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11. Navigate to Configuration Properties -> Linker -> Input -> Additional Dependencies 
and then append SystemLib.lib (see red circle in Figure 7.21). 

 

 
Figure 7.21 
 

12. Choose Device for the Target to establish connection with the PC. 

 

Figure 7.22 
 
Table 7.4 

Build menu Device 
CASIO ARMv5 Device DT-X100 / DT-X200 
CASIO ARMv7 Device IT-G500 WEC7 Model 
CASIO x86 Device Device Emulator for WEC7 
Windows Mobile 6 Professional Device IT-G500 WEH6.5 Model 
CASIO WEH6.5 WVGA Emulator Device Emulator for WEH6.5 

 
13. Navigate to Debug -> Start Debugging or Start Without Debugging from the Visual 

Studio 2008 menu. 
 
The project will be built and copied to the device. By default, it will be copied to \Program 
Files\<name of project> folder.  
 
Check that the program works correctly on the device. 
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8. Notes 

8.1 HWND_BROADCAST 

In Windows Embedded Compact 7, a specification of notifications changed. 
To receive notifications from system, an application should call RegisterWindowMessage function. 
An updated notifications is the following. 
 

Message Message Name 
Character Key TEXT( "SysKBDChrKey" ) 
Fn Key TEXT( "SysKBDFnKey" ) 
Cradle TEXT( "SysCradleDetect" ) 
Wake On TEXT( "SysWakeOn" ) 
SD Card TEXT( "SysCardDetect" ) 

 

Sample Code 

#define CHRKEY_MSG_NAME TEXT( "SysKBDChrKey" ) 

#define FNKEY_MSG_NAME TEXT( "SysKBDFnKey" ) 

#define IOBOX_MSG_NAME TEXT( "SysCradleDetect" ) 

#define WAKEON_MSG_NAME TEXT( "SysWakeOn" ) 

#define CARD_MSG_NAME  TEXT( "SysCardDetect" ) 

UINT  uMsgKbdChrKey = 0; 

UINT  uMsgKbdFnKey = 0; 

UINT  uMsgIoBoxDetect = 0; 

UINT  uMsgWakeOn = 0; 

UINT  uMsgCardDetect = 0; 

 

BOOL CALLBACK DialogProc(HWND hDlg, UINT message, WPARAM wParam, LPARAM 

lParam) 

{ 

 switch (message) 

 { 

  case WM_INITDIALOG: 

   uMsgKbdChrKey = RegisterWindowMessage(CHRKEY_MSG_NAME); 

   uMsgKbdFnKey = RegisterWindowMessage(FNKEY_MSG_NAME); 

   uMsgIoBoxDetect = RegisterWindowMessage(IOBOX_MSG_NAME); 

   uMsgWakeOn = RegisterWindowMessage(WAKEON_MSG_NAME); 

   uMsgCardDetect = RegisterWindowMessage(CARD_MSG_NAME); 

    (abbr.) 

   return TRUE; 

 

  default: 

   // Fn Key 

   if(message ==  uMsgKbdFnKey){ 

    (abbr.) 

   } 

 

   // Character Key 

   if(message == uMsgKbdChrKey){ 
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    (abbr.) 

   } 

 

   // Cradle 

   if(message == uMsgIoBoxDetect){ 

    (abbr.) 

   } 

 

   // Wake On 

   if(message == uMsgWakeOn){ 

    (abbr.) 

   } 

 

   // SD Card 

   if(message == uMsgCardDetect){ 

    (abbr.) 

   } 

   break; 

 } 

  return FALSE; 

} 

 

8.2 System Font 

In Windows Embedded Compact 7, the system font may be changed after ServicePack or Patch is 
installed. Specify the font without using the system font. 
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9. Resources 

Microsoft's own http://msdn.microsoft.com/mobility/default.aspx is an extremely comprehensive 
resource for programmers targeting WindowsCE .NET based devices. It includes links to most other 
useful web based resources. You will find detailed Software and Library manuals on 
http://world.casio.com/system/pa. 
 

http://msdn.microsoft.com/mobility/default.aspx�
http://world.casio.com/system/pa�
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